import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[^\\x00-\\x7F]+|[a-zA-Z'-]*";
final String string = "Kasapović\n"
+ "Subotić\n"
+ "O'Leary\n"
+ "Müller\n"
+ "Indriðason\n"
+ "ł ą ż ź\n"
+ "Strøm\n"
+ "Särlvik\n"
+ "Mihalović-Ann";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}