$re = '/[^\x00-\x7F]+|[a-zA-Z\'-]*/';
$str = 'Kasapović
Subotić
O\'Leary
Müller
Indriðason
ł ą ż ź
Strøm
Särlvik
Mihalović-Ann';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);