import re
regex = re.compile(r"[^\x00-\x7F]+|[a-zA-Z'-]*")
test_str = ("Kasapović\n"
"Subotić\n"
"O'Leary\n"
"Müller\n"
"Indriðason\n"
"ł ą ż ź\n"
"Strøm\n"
"Särlvik\n"
"Mihalović-Ann")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")