using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[^\x00-\x7F]+|[a-zA-Z'-]*";
string input = @"Kasapović
Subotić
O'Leary
Müller
Indriðason
ł ą ż ź
Strøm
Särlvik
Mihalović-Ann";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}