using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(?:Dear|H(?:ello|i))(?:[^\S\r\n]+[A-Z]\w*(?:[’'-]\w+)*\.?)+";
string input = @"Hello Mr. Smith
Dear Mr Smith
Hello Lisa
Dear Smith
Dear Smith-Walker
Dear Smith Adam Walker
Dear Smith O'Brian
Dear Smith O’Brian";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}