import re
regex = re.compile(r"\b(?:Dear|H(?:ello|i))(?:[^\S\r\n]+[A-Z]\w*(?:[’'-]\w+)*\.?)+", flags=re.MULTILINE)
test_str = ("Hello Mr. Smith\n"
"Dear Mr Smith\n"
"Hello Lisa\n"
"Dear Smith \n"
"Dear Smith-Walker\n"
"Dear Smith Adam Walker\n"
"Dear Smith O'Brian\n"
"Dear Smith O’Brian")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")