import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?:Dear|H(?:ello|i))(?:[^\\S\\r\\n]+[A-Z]\\w*(?:[’'-]\\w+)*\\.?)+";
final String string = "Hello Mr. Smith\n"
+ "Dear Mr Smith\n"
+ "Hello Lisa\n"
+ "Dear Smith \n"
+ "Dear Smith-Walker\n"
+ "Dear Smith Adam Walker\n"
+ "Dear Smith O'Brian\n"
+ "Dear Smith O’Brian";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}