package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b(?:Dear|H(?:ello|i))(?:[^\S\r\n]+[A-Z]\w*(?:[’'-]\w+)*\.?)+`)
var str = `Hello Mr. Smith
Dear Mr Smith
Hello Lisa
Dear Smith
Dear Smith-Walker
Dear Smith Adam Walker
Dear Smith O'Brian
Dear Smith O’Brian`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}