using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(?=[A-Z]{3}\b)A?([B-Z])A?\1A?\b";
string input = @"BBA -> true
ABB -> true
BAB -> true
CCA -> true
AAA -> false (change ""[B-Z]"" to ""[A-Z]"" to match this)
CCB -> false
ABC -> false
BAC -> false
BBBA -> false (there have to be only two)
ABBB -> false (there have to be only two)
ABBA -> false (there has to be only one A)
BABA -> false (there has to be only one A)
BBAA -> false (there has to be only one A)";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}