import Foundation
let pattern = #"\b(?=[A-Z]{3}\b)A?([B-Z])A?\1A?\b"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
BBA -> true
ABB -> true
BAB -> true
CCA -> true
AAA -> false (change "[B-Z]" to "[A-Z]" to match this)
CCB -> false
ABC -> false
BAC -> false
BBBA -> false (there have to be only two)
ABBB -> false (there have to be only two)
ABBA -> false (there has to be only one A)
BABA -> false (there has to be only one A)
BBAA -> false (there has to be only one A)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)