const regex = /\b(?=[A-Z]{3}\b)A?([B-Z])A?\1A?\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(?=[A-Z]{3}\\b)A?([B-Z])A?\\1A?\\b', 'gm')
const str = `BBA -> true
ABB -> true
BAB -> true
CCA -> true
AAA -> false (change "[B-Z]" to "[A-Z]" to match this)
CCB -> false
ABC -> false
BAC -> false
BBBA -> false (there have to be only two)
ABBB -> false (there have to be only two)
ABBA -> false (there has to be only one A)
BABA -> false (there has to be only one A)
BBAA -> false (there has to be only one A)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}