re = /\b(?=[A-Z]{3}\b)A?([B-Z])A?\1A?\b/m
str = 'BBA -> true
ABB -> true
BAB -> true
CCA -> true
AAA -> false (change "[B-Z]" to "[A-Z]" to match this)
CCB -> false
ABC -> false
BAC -> false
BBBA -> false (there have to be only two)
ABBB -> false (there have to be only two)
ABBA -> false (there has to be only one A)
BABA -> false (there has to be only one A)
BBAA -> false (there has to be only one A)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end