# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\b(?=[A-Z]{3}\b)A?([B-Z])A?\1A?\b"
test_str = ("BBA -> true\n"
"ABB -> true\n"
"BAB -> true\n"
"CCA -> true\n"
"AAA -> false (change \"[B-Z]\" to \"[A-Z]\" to match this)\n"
"CCB -> false\n"
"ABC -> false\n"
"BAC -> false\n"
"BBBA -> false (there have to be only two)\n"
"ABBB -> false (there have to be only two)\n"
"ABBA -> false (there has to be only one A)\n"
"BABA -> false (there has to be only one A)\n"
"BBAA -> false (there has to be only one A)")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.