import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?=[A-Z]{3}\\b)A?([B-Z])A?\\1A?\\b";
final String string = "BBA -> true\n"
+ "ABB -> true\n"
+ "BAB -> true\n"
+ "CCA -> true\n"
+ "AAA -> false (change \"[B-Z]\" to \"[A-Z]\" to match this)\n"
+ "CCB -> false\n"
+ "ABC -> false\n"
+ "BAC -> false\n"
+ "BBBA -> false (there have to be only two)\n"
+ "ABBB -> false (there have to be only two)\n"
+ "ABBA -> false (there has to be only one A)\n"
+ "BABA -> false (there has to be only one A)\n"
+ "BBAA -> false (there has to be only one A)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}