using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"("".*?,.*?""|.*?(?:,|$))";
string input = @"bob jones,123,55.6,,,""?????,???"",,0
jim neighbor,432,66.5,,,Andy ""Blank,,1
john smith,555,77.4,,,Some value,,2";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}