package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(".*?,.*?"|.*?(?:,|$))`)
var str = `bob jones,123,55.6,,,"?????,???",,0
jim neighbor,432,66.5,,,Andy "Blank,,1
john smith,555,77.4,,,Some value,,2`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}