import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\".*?,.*?\"|.*?(?:,|$))";
final String string = "bob jones,123,55.6,,,\"?????,???\",,0\n"
+ "jim neighbor,432,66.5,,,Andy \"Blank,,1\n"
+ "john smith,555,77.4,,,Some value,,2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}