re = /(".*?,.*?"|.*?(?:,|$))/m
str = 'bob jones,123,55.6,,,"?????,???",,0
jim neighbor,432,66.5,,,Andy "Blank,,1
john smith,555,77.4,,,Some value,,2'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end