// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)(".*?,.*?"|.*?(?:,|$))"#).unwrap();
let string = "bob jones,123,55.6,,,\"?????,???\",,0
jim neighbor,432,66.5,,,Andy \"Blank,,1
john smith,555,77.4,,,Some value,,2";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}