const regex = /(".*?,.*?"|.*?(?:,|$))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(".*?,.*?"|.*?(?:,|$))', 'gm')
const str = `bob jones,123,55.6,,,"?????,???",,0
jim neighbor,432,66.5,,,Andy "Blank,,1
john smith,555,77.4,,,Some value,,2`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}