$re = '/(".*?,.*?"|.*?(?:,|$))/m';
$str = 'bob jones,123,55.6,,,"?????,???",,0
jim neighbor,432,66.5,,,Andy "Blank,,1
john smith,555,77.4,,,Some value,,2';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);