#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(^[\s]*[-+]?[0-9]*?\.?[0-9]+([eE][-+]?[0-9]+)?[\s]*$|^[\s]*[-+]?[0-9]+\.?[\s]*$)"
Local $sString = "0" & @CRLF & _
"0." & @CRLF & _
"0.0" & @CRLF & _
"0.00" & @CRLF & _
"0.0e0" & @CRLF & _
"0.0e-0" & @CRLF & _
"0.0e+0 " & @CRLF & _
"+0 " & @CRLF & _
"+0. " & @CRLF & _
"+0.0" & @CRLF & _
"+0.00" & @CRLF & _
"+0.0e0" & @CRLF & _
"+0.0e-0" & @CRLF & _
"+0.0e+0" & @CRLF & _
"-0 " & @CRLF & _
"-0." & @CRLF & _
"-0.0" & @CRLF & _
"-0.00" & @CRLF & _
"-0.0e0" & @CRLF & _
"-0.0e-0" & @CRLF & _
"-0.0e+0" & @CRLF & _
"1." & @CRLF & _
"2." & @CRLF & _
"3." & @CRLF & _
"4." & @CRLF & _
"-1." & @CRLF & _
"-2." & @CRLF & _
"-3." & @CRLF & _
"-4." & @CRLF & _
".1" & @CRLF & _
".2" & @CRLF & _
".3" & @CRLF & _
".4" & @CRLF & _
"-.1" & @CRLF & _
"-.2" & @CRLF & _
"-.3" & @CRLF & _
"-.4" & @CRLF & _
"1.0" & @CRLF & _
"3.0" & @CRLF & _
"4.0" & @CRLF & _
"5.0" & @CRLF & _
"-1.0" & @CRLF & _
"-2.0" & @CRLF & _
"-3.0" & @CRLF & _
"-4.0" & @CRLF & _
"-5.0" & @CRLF & _
"5.0123456" & @CRLF & _
"-5.012345678" & @CRLF & _
"-1" & @CRLF & _
"10" & @CRLF & _
"-10" & @CRLF & _
"10.0" & @CRLF & _
"-10.0" & @CRLF & _
"-10.01234" & @CRLF & _
"10.01234" & @CRLF & _
"0" & @CRLF & _
"1" & @CRLF & _
"01" & @CRLF & _
"001" & @CRLF & _
" 1 " & @CRLF & _
"" & @CRLF & _
"Ne doit pas être validé" & @CRLF & _
"" & @CRLF & _
"." & @CRLF & _
"1.." & @CRLF & _
".1." & @CRLF & _
"..1" & @CRLF & _
"toto" & @CRLF & _
"1a" & @CRLF & _
"a1" & @CRLF & _
"a1a" & @CRLF & _
"1 a" & @CRLF & _
"a 1" & @CRLF & _
"a 1 a" & @CRLF & _
"-.1." & @CRLF & _
"+.1."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")