// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(^[\s]*[-+]?[0-9]*?\.?[0-9]+([eE][-+]?[0-9]+)?[\s]*$|^[\s]*[-+]?[0-9]+\.?[\s]*$)").unwrap();
let string = "0
0.
0.0
0.00
0.0e0
0.0e-0
0.0e+0
+0
+0.
+0.0
+0.00
+0.0e0
+0.0e-0
+0.0e+0
-0
-0.
-0.0
-0.00
-0.0e0
-0.0e-0
-0.0e+0
1.
2.
3.
4.
-1.
-2.
-3.
-4.
.1
.2
.3
.4
-.1
-.2
-.3
-.4
1.0
3.0
4.0
5.0
-1.0
-2.0
-3.0
-4.0
-5.0
5.0123456
-5.012345678
-1
10
-10
10.0
-10.0
-10.01234
10.01234
0
1
01
001
1
Ne doit pas ĂȘtre validĂ©
.
1..
.1.
..1
toto
1a
a1
a1a
1 a
a 1
a 1 a
-.1.
+.1.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}