package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(^[\s]*[-+]?[0-9]*?\.?[0-9]+([eE][-+]?[0-9]+)?[\s]*$|^[\s]*[-+]?[0-9]+\.?[\s]*$)`)
var str = `0
0.
0.0
0.00
0.0e0
0.0e-0
0.0e+0
+0
+0.
+0.0
+0.00
+0.0e0
+0.0e-0
+0.0e+0
-0
-0.
-0.0
-0.00
-0.0e0
-0.0e-0
-0.0e+0
1.
2.
3.
4.
-1.
-2.
-3.
-4.
.1
.2
.3
.4
-.1
-.2
-.3
-.4
1.0
3.0
4.0
5.0
-1.0
-2.0
-3.0
-4.0
-5.0
5.0123456
-5.012345678
-1
10
-10
10.0
-10.0
-10.01234
10.01234
0
1
01
001
1
Ne doit pas être validé
.
1..
.1.
..1
toto
1a
a1
a1a
1 a
a 1
a 1 a
-.1.
+.1.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}