import Foundation
let pattern = #"(^[\s]*[-+]?[0-9]*?\.?[0-9]+([eE][-+]?[0-9]+)?[\s]*$|^[\s]*[-+]?[0-9]+\.?[\s]*$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
0
0.
0.0
0.00
0.0e0
0.0e-0
0.0e+0
+0
+0.
+0.0
+0.00
+0.0e0
+0.0e-0
+0.0e+0
-0
-0.
-0.0
-0.00
-0.0e0
-0.0e-0
-0.0e+0
1.
2.
3.
4.
-1.
-2.
-3.
-4.
.1
.2
.3
.4
-.1
-.2
-.3
-.4
1.0
3.0
4.0
5.0
-1.0
-2.0
-3.0
-4.0
-5.0
5.0123456
-5.012345678
-1
10
-10
10.0
-10.0
-10.01234
10.01234
0
1
01
001
1
Ne doit pas ĂȘtre validĂ©
.
1..
.1.
..1
toto
1a
a1
a1a
1 a
a 1
a 1 a
-.1.
+.1.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)