import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^[\\s]*[-+]?[0-9]*?\\.?[0-9]+([eE][-+]?[0-9]+)?[\\s]*$|^[\\s]*[-+]?[0-9]+\\.?[\\s]*$)";
final String string = "0\n"
+ "0.\n"
+ "0.0\n"
+ "0.00\n"
+ "0.0e0\n"
+ "0.0e-0\n"
+ "0.0e+0 \n"
+ "+0 \n"
+ "+0. \n"
+ "+0.0\n"
+ "+0.00\n"
+ "+0.0e0\n"
+ "+0.0e-0\n"
+ "+0.0e+0\n"
+ "-0 \n"
+ "-0.\n"
+ "-0.0\n"
+ "-0.00\n"
+ "-0.0e0\n"
+ "-0.0e-0\n"
+ "-0.0e+0\n"
+ "1.\n"
+ "2.\n"
+ "3.\n"
+ "4.\n"
+ "-1.\n"
+ "-2.\n"
+ "-3.\n"
+ "-4.\n"
+ ".1\n"
+ ".2\n"
+ ".3\n"
+ ".4\n"
+ "-.1\n"
+ "-.2\n"
+ "-.3\n"
+ "-.4\n"
+ "1.0\n"
+ "3.0\n"
+ "4.0\n"
+ "5.0\n"
+ "-1.0\n"
+ "-2.0\n"
+ "-3.0\n"
+ "-4.0\n"
+ "-5.0\n"
+ "5.0123456\n"
+ "-5.012345678\n"
+ "-1\n"
+ "10\n"
+ "-10\n"
+ "10.0\n"
+ "-10.0\n"
+ "-10.01234\n"
+ "10.01234\n"
+ "0\n"
+ "1\n"
+ "01\n"
+ "001\n"
+ " 1 \n\n"
+ "Ne doit pas être validé\n\n"
+ ".\n"
+ "1..\n"
+ ".1.\n"
+ "..1\n"
+ "toto\n"
+ "1a\n"
+ "a1\n"
+ "a1a\n"
+ "1 a\n"
+ "a 1\n"
+ "a 1 a\n"
+ "-.1.\n"
+ "+.1.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}