# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\b0|([0-F])(?=0*~[0-F]*?\1([0-F]))|~[0-F]*/$2/g;t' <<< "0109~0123456789ABCDEF0"