using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b0|([0-F])(?=0*~[0-F]*?\1([0-F]))|~[0-F]*";
string substitution = @"$2";
string input = @"0109~0123456789ABCDEF0";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}