import re
regex = re.compile(r"\b0|([0-F])(?=0*~[0-F]*?\1([0-F]))|~[0-F]*")
test_str = "0109~0123456789ABCDEF0"
subst = "$2"
result = regex.sub(subst, test_str)
if result:
print(result)