#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\b0|([0-F])(?=0*~[0-F]*?\1([0-F]))|~[0-F]*"
Local $sString = "0109~0123456789ABCDEF0"
Local $sSubst = "$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)