use strict;
my $str = '0109~0123456789ABCDEF0';
my $regex = qr/\b0|([0-F])(?=0*~[0-F]*?\1([0-F]))|~[0-F]*/p;
my $subst = '$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";