$re = '/\b0|([0-F])(?=0*~[0-F]*?\1([0-F]))|~[0-F]*/';
$str = '0109~0123456789ABCDEF0';
$subst = "$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;