import Foundation
let pattern = #"\b0|([0-F])(?=0*~[0-F]*?\1([0-F]))|~[0-F]*"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"0109~0123456789ABCDEF0"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)