using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=Field Ticket Ref Number.)(\S+)|(?<=Field Ticket Ref No.)(\S+)|(?<=Field Ticket Ref No.\s)(\S+)";
string input = @"Field Ticket Ref Number 1012930.100
Field Ticket Ref No:XJ19-JI20
Field Ticket Ref No- ODJC.10J9
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}