import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=Field Ticket Ref Number.)(\\S+)|(?<=Field Ticket Ref No.)(\\S+)|(?<=Field Ticket Ref No.\\s)(\\S+)";
final String string = "Field Ticket Ref Number 1012930.100\n\n"
+ "Field Ticket Ref No:XJ19-JI20\n\n"
+ "Field Ticket Ref No- ODJC.10J9\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}