re = /(?<=Field Ticket Ref Number.)(\S+)|(?<=Field Ticket Ref No.)(\S+)|(?<=Field Ticket Ref No.\s)(\S+)/m
str = 'Field Ticket Ref Number 1012930.100
Field Ticket Ref No:XJ19-JI20
Field Ticket Ref No- ODJC.10J9
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end