$re = '/(?<=Field Ticket Ref Number.)(\S+)|(?<=Field Ticket Ref No.)(\S+)|(?<=Field Ticket Ref No.\s)(\S+)/m';
$str = 'Field Ticket Ref Number 1012930.100
Field Ticket Ref No:XJ19-JI20
Field Ticket Ref No- ODJC.10J9
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);