const regex = /(?<=Field Ticket Ref Number.)(\S+)|(?<=Field Ticket Ref No.)(\S+)|(?<=Field Ticket Ref No.\s)(\S+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=Field Ticket Ref Number.)(\\S+)|(?<=Field Ticket Ref No.)(\\S+)|(?<=Field Ticket Ref No.\\s)(\\S+)', 'gm')
const str = `Field Ticket Ref Number 1012930.100
Field Ticket Ref No:XJ19-JI20
Field Ticket Ref No- ODJC.10J9
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}