import re
regex = re.compile(r"(?<=Field Ticket Ref Number.)(\S+)|(?<=Field Ticket Ref No.)(\S+)|(?<=Field Ticket Ref No.\s)(\S+)", flags=re.MULTILINE)
test_str = ("Field Ticket Ref Number 1012930.100\n\n"
"Field Ticket Ref No:XJ19-JI20\n\n"
"Field Ticket Ref No- ODJC.10J9\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")