import Foundation
let pattern = #"(?<=Field Ticket Ref Number.)(\S+)|(?<=Field Ticket Ref No.)(\S+)|(?<=Field Ticket Ref No.\s)(\S+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Field Ticket Ref Number 1012930.100
Field Ticket Ref No:XJ19-JI20
Field Ticket Ref No- ODJC.10J9
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)