#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?mu)[^\p{Alnum}\s]"
Local $sString = "!\"#$%&'()*+,-./:;<=>?@[\\]^_`{|}~(hello)" & @CRLF & _
"foo bar baz"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)