$re = '/[^\p{Alnum}\s]/mu';
$str = '!\\"#$%&\'()*+,-./:;<=>?@[\\\\]^_`{|}~(hello)
foo bar baz';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;