re = /[^\p{Alnum}\s]/m
str = '!\\"#$%&\'()*+,-./:;<=>?@[\\\\]^_`{|}~(hello)
foo bar baz'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result