const regex = new RegExp('[^\\p{Alnum}\\s]', 'gmu')
const str = `!\\"#\$%&'()*+,-./:;<=>?@[\\\\]^_\`{|}~(hello)
foo bar baz`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);