# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(#'YOUR_ANSWER.*)(?:\R(?!\h*#'END_ANSWER$).*)*(\R\h*#'END_ANSWER)$/$1\nspace for answer$2/gm;t' <<< "#'YOUR_ANSWER
As_samp2 = 36
As_samp3 = 38
#'END_ANSWER
"