use strict;
my $str = '#\'YOUR_ANSWER
As_samp2 = 36
As_samp3 = 38
#\'END_ANSWER
';
my $regex = qr/^(#'YOUR_ANSWER.*)(?:\R(?!\h*#'END_ANSWER$).*)*(\R\h*#'END_ANSWER)$/mp;
my $subst = '$1\\nspace for answer$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";