#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(#'YOUR_ANSWER.*)(?:\R(?!\h*#'END_ANSWER$).*)*(\R\h*#'END_ANSWER)$"
Local $sString = "#'YOUR_ANSWER" & @CRLF & _
" As_samp2 = 36" & @CRLF & _
" As_samp3 = 38" & @CRLF & _
"" & @CRLF & _
" #'END_ANSWER" & @CRLF & _
""
Local $sSubst = "$1\nspace for answer$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)