const regex = /^(#'YOUR_ANSWER.*)(?:\R(?!\h*#'END_ANSWER$).*)*(\R\h*#'END_ANSWER)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(#\'YOUR_ANSWER.*)(?:\\R(?!\\h*#\'END_ANSWER$).*)*(\\R\\h*#\'END_ANSWER)$', 'gm')
const str = `#'YOUR_ANSWER
As_samp2 = 36
As_samp3 = 38
#'END_ANSWER
`;
const subst = `$1\nspace for answer$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);