import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(#'YOUR_ANSWER.*)(?:\\R(?!\\h*#'END_ANSWER$).*)*(\\R\\h*#'END_ANSWER)$";
final String string = "#'YOUR_ANSWER\n"
+ " As_samp2 = 36\n"
+ " As_samp3 = 38\n\n"
+ " #'END_ANSWER\n";
final String subst = "$1\\nspace for answer$2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}