$re = '/^(#\'YOUR_ANSWER.*)(?:\R(?!\h*#\'END_ANSWER$).*)*(\R\h*#\'END_ANSWER)$/m';
$str = '#\'YOUR_ANSWER
As_samp2 = 36
As_samp3 = 38
#\'END_ANSWER
';
$subst = "$1\nspace for answer$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;